not able to create a cluster in EC2

User 2387 | 10/9/2015, 2:44:57 PM

I am trying to create a cluster in EC2 (with the code below, with the right awsaccesskey, awssecretaccesskey and s3path) and I am getting this error: "RuntimeError: Unable to start host(s). Please terminate manually from the AWS console." However, the cluster seems to be created in the proper way, I can see all the instances running on the AWS console. I am new to Graphlab, but I was able to run this code yesterday night with no problems. I have tried today many times (from windows and ubuntu computers) but always get the same error. Any ideas?

import graphlab as gl ec2conf = gl.deploy.Ec2Config(region='us-east-1', instancetype='m3.2xlarge',
awsaccesskeyid='myaccesskeyhere', awssecretaccesskey='mysecretaccesskeyhere', numhosts=4) ​ ec2 = gl.deploy.ec2cluster.create(name='ec2', s3path='s3://pathhere', ec2config=ec2_conf)

This is the log of the error:


RuntimeError Traceback (most recent call last) <ipython-input-2-811f3e22dad1> in <module>() 6 ec2 = gl.deploy.ec2cluster.create(name='awsec2', 7 s3path='s3://texata-round2', ----> 8 ec2config=ec2_conf)

/home/sandrovegapons/anaconda/lib/python2.7/site-packages/graphlab/deploy/ec2cluster.pyc in create(name, s3path, ec2config, numhosts, additionalpackages, idleshutdowntimeout) 81 cluster = Ec2Cluster(ec2config, s3path, name, numhosts, additionalpackages, idleshutdown_timeout) 82 ---> 83 cluster.start() 84 return cluster 85

/home/sandrovegapons/anaconda/lib/python2.7/site-packages/graphlab/deploy/ec2cluster.pyc in start(self) 231 self.numhosts, 232 self.additionalpackages, --> 233 self.idleshutdowntimeout 234 ) 235 self.save()

/home/sandrovegapons/anaconda/lib/python2.7/site-packages/graphlab/deploy/executionenvironment.pyc in startcommanderhost(envname, config, s3folderpath, numhosts, additionalpackages, idleshutdowntimeout) 367 waitforhosttostart_up() 368 except: --> 369 raise RuntimeError('Unable to start host(s). Please terminate ' 370 'manually from the AWS console.') 371

RuntimeError: Unable to start host(s). Please terminate manually from the AWS console.

Comments

User 2387 | 10/9/2015, 9:51:42 PM

Never mind...problem solved. It was related to firewall configuration on some machines at my workplace...