Using SDK with Sframe Open Source

User 2352 | 10/2/2015, 9:37:45 PM

I am trying to use the graphlab SDK with the open source SFrame project, but I am getting errors when importing any of the example shared libraries into python. The steps that I followed were grab the latest SFrame from github. Configure and build. I can successfully run through some of the examples using the sframe module in python, so I'm pretty sure that is all set. I then pulled down the latest SDK from github. Execute a make in the SDK directory. I start up python, import sframe and then try to import example1, but I am getting an error in python:

import example1 [INFO] Start server at: ipc:///tmp/graphlabserver-32681 - Server binary: /home/kanhofer/git/Projects/SFrame/release/osssrc/unity/python/sframe/unityserver - Server log: /tmp/sframeserver1443821045.log [INFO] GraphLab Server Version: 0.1.internal Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: ./example1.so: undefined symbol: ZN8graphlab18toolkitclassbase9list_keysEv

I get similar errors for the other two included examples. Thinking this may be an issue with the SFrame project I tried with the latest graphlab create (1.6 I believe), but I still get the same error. Am I missing something with how to set up the SDK?

Comments

User 16 | 10/5/2015, 11:20:48 PM

Hi Kanhofer,

I apologize for this issue. I've just updated the SDK repository to work with the most recent version of SFrame (and GraphLab Create). Please pull the most recent changes from the GraphLab-Create-SDK repository and try again.

I just tried example1 with the most recent version of SFrame and it worked fine for me. Let me know if you have any issues.

Thanks, Toby


User 2352 | 10/6/2015, 3:57:45 PM

Looks like everything is happy now. Thanks!


User 940 | 10/6/2015, 6:46:11 PM

@kanhofer ,

Happy to hear that your issues have been resolved. Let us know if you have any more problems!

Cheers! -Piotr