Installation error | Later Import error

User 2343 | 9/30/2015, 8:59:34 PM

Hi people,

I have tried to install Graphlab Create using the section "Option 2: Install in Python environment using virtualenv" of this link - personal installation link removed

I am already having a python 3.3 installation. For graphlab create, I have followed the steps -

  1. installed python2.7 (alongside python3.3)
  2. installed virtualenv (this has installed inside python3.3)
  3. created a virtual env called dato-env (created this using python2.7.exe)
  4. activated the env
  5. installed IPython Notebook inside the env
  6. tried to install graphlab create inside the env

All went well till step5. During graphlab create installation, it is giving me the error - "GraphLab Create currently supports only 64-bit operating systems, and only recent Linux/OSX architectures. Please install using a supported version. Your architecture is currently: 32bit"

I am using a windows8 laptop which is 64 bit. So I am pretty confused about the error. Could you please help me with this ? I am attaching the log that I generated during graphlab create installation. Later, when I am trying to import the module, it gives error "ImportError: No module named cy_unity"


User 9 | 10/1/2015, 4:37:08 PM

Looks like you did everything right.

Can you attach a screen shot of your System window in Control Panel? We definitely want to know if GraphLab Create is reporting the wrong OS architecture. Thanks for your help.

User 2498 | 10/27/2015, 6:50:12 PM

I have a simmilar problem. I'm running on win 10 and using PyCharm. I followe this thread : And get the same errors as @SubhasisM Any way to solve this issue?

User 4 | 10/27/2015, 9:28:24 PM

Hi @OmriB, please ensure that all of the dependencies in the stack (Python and PyCharm) are 64-bit versions. If you are using a 32-bit version of Python or PyCharm, that may appear equivalent to using a 32-bit OS, and a 64-bit build of GraphLab Create will not work.

If you are using 64-bit versions of everything, it could be a PATH issue. On Windows, GraphLab Create requires the directory containing python27.dll to be in your PATH environment variable. Can you please check whether the directory containing python27.dll is in your PATH environment variable? Thanks!

User 2498 | 10/28/2015, 5:40:45 PM

Ok PyCharm community on windows seems to be 32 bit - Can you confirm that ? Is there any work around to work with Graph lab on Pycharm ? Is there any other recomended and free IDE that will get the Job DONE? Thanks

User 4 | 10/28/2015, 8:43:27 PM

Hi @OmriB -- if PyCharm Community on Windows is only 32-bit, it may prevent it from working from GraphLab Create. I'm not sure; it's possible that a 32-bit IDE can still work with our package as long as it's using a 64-bit Python interpreter, but I have not tried it. You may need to configure it extensively to make sure the entire chain is using 64-bit components underneath the 32-bit IDE, if this is possible.

Most Python programmers I know don't use a traditional IDE like PyCharm. A combination of the REPL (read-evaluate-print loop) provided by an interactive python or ipython process, and/or IPython Notebook (web UI with executable cells of Python code) seem to be the preferred way to do interactive development of Python, especially for data science. I'd recommend trying IPython Notebook, which can be launched from the command line of a Python environment. The Anaconda distribution of Python makes it very easy to get started with IPython Notebook on Windows, or if your primary purpose is to use GraphLab Create, I would recommend the Dato Launcher, which packages Anaconda and GraphLab Create and gives you a GUI to launch IPython Notebook.

User 5275 | 6/10/2016, 4:02:41 PM

Thanks guys. I have the same issue -- can't run pycharm+graphlab, though graphlab runs fine from the terminal. @Zach -- would appreciate if you have any update on this issue. Pycharm is a great IDE that is widely used, so worth supporting it :smile: .

User 4 | 6/10/2016, 6:00:47 PM

Hi @GiA, just to be clear, we do support running in PyCharm. However, it can be difficult to configure the IDE to execute Python in the right environment (the one where graphlab-create is installed via pip), and difficult to make sure the right dependencies are satisfied (64-bit PyCharm, 64-bit Python, etc.). Because of that difficulty I recommended an alternate path for those who want to get up and running quickly to try GraphLab Create.

If all of the requirements are satisfied and PyCharm is configured correctly, it should definitely work and we do support running in that configuration. Unfortunately we can't support all possible configurations due to the way GraphLab Create runs a native process on the machine and hooks into the Python interpreter. For performance and scalability, the GraphLab Create engine and toolkits are implemented in C++, rather than directly in Python. The C++ bits are compiled to 64-bit native binaries for each system, and call into Python using the Python-version-specific ABI, so we can only support a limited set of platforms and Python versions: Python 2.7 (with beta releases for Python 3.4 and Python 3.5), 64-bit only, on Mac OS X 10.8+, 64-bit Windows 7+, and various 64-bit Linux distributions with GLIBC version >= 2.11. Please make sure your hardware, operating system, Python version, and possibly PyCharm version meet these requirements.

I did manage to get PyCharm working on my machine, on Mac OS X. Here are the steps I followed:

  • Follow the normal GraphLab Create installation steps, either using Dato Launcher (which installs and/or configures Anaconda), or manually installing Anaconda with a dato-env environment on the command line.
  • Install PyCharm Community Edition 2006.1.
  • Before opening or creating a project, in the welcome screen, select "Configure" -> "Preferences".
  • Select "Project Interpreter" on the left.
  • Select the dato-env environment where GraphLab Create is installed (for me, this is "~/anaconda/envs/dato-env/bin/python, and shows a Python 2.7.11 after it is selected).
  • Hit Apply and then OK.
  • Wait while the "Updating Skeletons" dialog is open. This seems to take a very long time but I don't think it's safe to put it in the background and continue (GraphLab Create may not work until it finishes?).
  • Click Create New Project (you could probably open a project, too), giving it a name, and making sure the dato-env environment is selected as the Python environment for this project.
  • After creating a new Python file, the "Indexing" process seems to take a very long time. While it's running I don't seem to be able to run the Python file from within PyCharm.
  • Once the "Indexing" process finishes, I am able to run the project, and GraphLab Create works within this environment.

The result will look something like this:

User 5275 | 6/10/2016, 7:14:41 PM

Eureka! needed to change the virutalenv base interpreter to use the Anaconda2 path. process sometime throws this: "Exception in thread metrics-worker (most likely raised during interpreter shutdown):" thank you @Zach !

User 4 | 6/10/2016, 7:19:03 PM

@GiA you're welcome! I'm not sure what that exception thing is -- it may be an interaction between PyCharm and GLC, but is probably nothing to worry about if the code executes fine before shutting down the interpreter.