GraphLab Create import errors on pyCharm

User 2341 | 9/29/2015, 1:42:54 PM

I am using PyCharm and installed GraphLab Create library, but library is not successfully imported, i get errors and do not have idea how can resolve them. PS. on the ipython console everything works fine

Comments

User 940 | 10/5/2015, 7:37:12 PM

Hi @"Adas Ur" ,

It's a bit hard to exactly tell what's going on here, so I tried to install GraphLab w/PyCharm with success. Could you try to reproduce the following steps and let me know if it works?

Select File --> Settings --> Project Interpreter and then click the little gear next to the Project Interpreter drop down, and select "Create Virtualenv". Once created, hit the green "+" sign and install GraphLab Create. You should now be able to import graphlab from within PyCharm.

Cheers! -Piotr


User 5275 | 6/10/2016, 6:11:21 PM

Hi Piotr,

i have the same issue as @"Adas Ur". i tried to create a Vritualenv but it doesn't work. it seems to be a problem with sframe. When i'm creating the on top of a 2.7 baseline the package is added to the installed packages but the code fails on the import statement. When trying on top of a 3.5 baseline the graphlab create package fails when trying to add it to the virtualenv packages.

when running IDLE the graphlab package runs fine (the idle opens 3.5.1)

Any suggestion/update on this issue? I saw several posts on this but no solution.

Thanks, GiA