AttributeError: 'module' object has no attribute 'connect' with graphlab-create 1.6.1

User 2292 | 9/26/2015, 6:54:13 PM

I installed graphlab-create==1.6.1, to overcome "Model Evaluation is not yet available on regression model type." during "model.show(view='Evaluation')"

Now I'm getting following unable import graphlab

C:\Users\IBMADMIN\AppData\Local\Dato\Dato Launcher\lib\site-packages\graphlab\graphlab\graphlab\graphlab_init__.py in <module>() 52 from graphlab.util import setruntimeconfig 53 ---> 54 import graphlab.connect as _mt 55 import graphlab.connect.aws as aws 56 import visualization

AttributeError: 'module' object has no attribute 'connect'

Comments

User 2292 | 9/26/2015, 7:39:09 PM

I uninstalled dato launcher 1.0.0.exe and I downloaded and reinstalled dato-launcher-1.1.0 and downloaded 1.6.1 version, now I'm able to import graphlab.

But the original error I had with "model.show(view='Evaluation')", "Model Evaluation is not yet available on regression model type." is still there with this new version


User 2292 | 9/27/2015, 11:00:59 PM

Got it working, for some reason the notebook was not picking up 1.6.1, after some retries and pip upgrade, I was able to get it working.