Plots not displaying

User 2297 | 9/24/2015, 2:21:03 PM

Hello, I am having trouble displaying the plots.When i run SFrame.show() i get all other data corrects but the plots tab seems non functional. Then after that i viewing a particular plot for select parameters and i was able to view that plot alone. And also i am not able view the plots inline at all. For additional info i did the system wide install and i run windows 7 64 bit with ipython 2.7 Anaconda and i run chrome version 45.0.2454.99.

Thanks in advance -Sagar

Comments

User 4 | 9/24/2015, 6:20:20 PM

Hi @Sagarz, we are fixing the inline plot issue, and the fix will be available in the next point release very soon. In the meantime, the browser target should work. If the plot buttons are not available for columns they should be enabled for (for example, with int columns on both axes, the Scatter Plot, Heat Map, and others should all be available), you can try refreshing the browser window. It could be a temporary issue that would be resolved by a refresh; if so we will investigate and fix that issue in a future release as well. Hope that helps!


User 2297 | 9/24/2015, 6:34:03 PM

hi @Zach I tried refreshing,restarting the kernel and the ipython notebook but still i am not getting the plots in the browser and my parameters meet the given condition ans they both are of type int.


User 4 | 9/24/2015, 6:46:08 PM

Hi @Sagarz, what version of GraphLab Create are you using? This is what I see when using GraphLab Create 1.6 with a Scatter Plot of two int columns:


User 2297 | 9/24/2015, 7:44:15 PM

I believe i have the latest one installed


User 2297 | 9/27/2015, 1:45:19 PM

why is no one replying?


User 4 | 9/27/2015, 4:29:45 PM

Hi @Sagarz, we just released 1.6.1 which might solve this issue. Can you please give it a try and let us know if that fixes this issue? pip install --upgrade graphlab-create==1.6.1.


User 2297 | 9/29/2015, 3:13:25 PM

I have upgraded it and its working..Thanks


User 4 | 9/29/2015, 9:00:46 PM

Great, glad to hear this is now working for you!