Plots not working

User 2303 | 9/24/2015, 5:47:36 AM

Currently I am exploring graphlab and I was trying to plot different plots (Scatter, Boxwhisker) which does not work. It just shows me summary statistics for every time I call show() function.

For example:

  1. graphlab.canvas.set_target('ipynb')
  2. sales.show(view="Scatter Plot", x="sqft_living", y="price")
  3. sales.show()

Lines 2 and 3 shows the same output which is summary statistics.

FYI I am using ipython notebook on windows and I have installed graphlab using pip

Comments

User 2308 | 9/24/2015, 6:02:15 PM

Actually I'm having the same problem. Even when using the GraphLab Canvas explorer (not the set_target option to include the visualization in the notebook), the plots section is not available.

I'm also working in Windows. Changing the web browser didn't solved the problem. Does anybody know what can be happening?

Thanks in advance.


User 1178 | 9/24/2015, 6:28:43 PM

Hello,

This maybe a refresh problem. Does it work if you go to the Canva view, manually select X and Y axis and the plot type, can you resolve it by refreshing your window?

We are looking at this now but the above action should be able to unblock you for now.

Thanks! Ping


User 2308 | 9/24/2015, 6:58:39 PM

Hello Ping,

refreshing indeed work in the Canva view, thank you! However, the other plotting options still appear as blocked in the Canva view (they can't be selected). In ipynb the problem persists, if set_target is used, only the summaries are shown (even though a concrete type of plot is indicated).

Sergio


User 2316 | 9/25/2015, 11:58:42 AM

This should help.


User 2308 | 10/2/2015, 7:21:04 AM

Hello everyone! I'm experiencing problems again with the use of plots in ipynb. After updating GraphLab to the new 1.6.1 version, if I set_target to the ipynb, the .show() doesn't actually show anything when I run the command. The Canvas view works fine in this case.

Last time Anirudh solved my problem in the blink of an eye (thank you so much!), so I come here again to ask the experts in the forum for some help.

Thank you! Sergio


User 2308 | 10/2/2015, 7:34:43 AM

Nevermind, I uninstalled and reinstalled GraphLab from the terminal and now it works fine.

Thanks anyway! Sergio


User 940 | 10/6/2015, 5:56:59 PM

@sergiodh ,

Happy to hear this!

Cheers! -Piotr


User 2394 | 10/11/2015, 3:32:24 AM

How do you "uninstalled and reinstalled GraphLab"? I tried the pip upgrade twice, and show() doesn't work inside the iPython notebook. Thankfully, if i set the target to 'browser', it seems to work.


User 2540 | 11/3/2015, 5:39:42 PM

I'm having the same problem, I was trying to plot different plots but does not work, the plots section is not available.I'm also working in Windows. i've execute these line of code: graphlab.canvas.set_target('ipynb') sf['age'].show(view = 'Categorical')

Does anyone can help? Thanks.


User 2534 | 12/3/2015, 7:06:27 AM

I'm having the same problem where set_target('ipynb') leads to plots not showing anywhere. Note that I'm using 1.7.1 gpu version. I also tried doing the manual code edits, suggested here (https://pythonandr.wordpress.com/2015/09/25/scatter-plot-bug-fix-in-datos-graphlab-create-ml-package-in-python/) to sframe.py and didn't work.


User 2534 | 12/5/2015, 6:00:09 PM

As an update, it appears when I stick to the normal CPU graphlab (1.7.1), plots can still show inside IPython notebooks (ie: setting canvas target to ipynb works). However, when I try to upgrade to the latest GPU version (1.7.1), plots no longer show inside IPython notebook.


User 2770 | 12/9/2015, 3:05:36 PM

Similar issue as @bluelight , I had just the CPU version installed this morning and when I set the target to ipynb I was able to call show() and the data visualized inline correctly. However, after updating to the GPU version show() no longer worked. To visualize the data I had to change the target back to browser and then reload the Canvas after it opens.


User 15 | 12/9/2015, 10:49:13 PM

Thanks. This is a known issue, we're working to fix it.


User 2799 | 12/12/2015, 5:29:47 AM

You may already be aware of this issue, but it looks like the version string "1.7.1.gpu" is causing 404 errors for web resources (i.e., https://dato.com/files/canvas/1.7.1.gpu/css/canvas.css 404s but https://dato.com/files/canvas/1.7.1/css/canvas.css does not). The culprit may be the get_asset_url method in canvas/target.py


User 1190 | 12/14/2015, 8:50:43 PM

You are right. This is a known issue and we will fix it. You can fix it locally by hard code the resource url in canvas/target.py


User 2989 | 1/10/2016, 7:53:55 AM

I also face the same problem. When I install version 1.7.1, show() works well when figure shows in the new page when the target is the browser. When I use graphlab.canvas.set_target('ipynb'), I will be waiting few minutes for the figure shows in the following in the notebook the first time. Then it seems everything goes well. But in this version, I try following lines of code, there is a RuntimeError.

def transform_country(country): if country == 'USA': return 'United States' else: return country

sf['Country'].apply(transform_country)

I solved this problem about .apply() by update the version to 1.7.1.94 in http://forum.dato.com/discussion/1499/graphlab-create-using-anaconda-ipython-notebook-lambda-workers-did-not-start Well, now, the show() works well when open a new page showing the figure, when I run graphlab.canvas.set_target('ipynb'), nothing shows up in the following line. I rerun many times. The plot just not working. I'm confusing.

I use window 7 64 professional, the browser is google chorm 46.0.2490.86 m. I decide temporally use browser as the target to show figure. But I still want to solve this problem, let the figure show in the notebook.

Thanks in advance


User 3000 | 1/11/2016, 4:47:42 PM

Hi,

I have the same problem, I set the command graphlab.canvas.set_target('ipynb'), but nothing is shown in the notebook.

Initially, I had the same problem with .apply() funtion and "lambda workers", and applied the same solution from Hoytak, explained in:

http://forum.dato.com/discussion/1499/graphlab-create-using-anaconda-ipython-notebook-lambda-workers-did-not-start/p1

After that, .apply() works, but set_target('ipynb') does not.

I have Windows 10. I have disabled the pop-up blockers, and tried with 3 browswers (Edge, Chrome and Firefox), but problem remains.

Does anyone have any solution?

Thanks in advance, Ricardo.


User 2989 | 1/17/2016, 5:26:05 AM

Well, my question solved. Update the graphlab to the newest version 1.8. Everything works well. Thank the Dato team to fixed the bugs.


User 9 | 1/17/2016, 9:06:46 PM

I am glad this issue is resolved!

Thanks for reporting bugs. We will do our best to fix quickly.

Tim


User 5257 | 6/1/2016, 11:40:42 PM

Same problem... Had a notebook that was working fine-- updated to graphlab 1.9 and it no longer works. This is for graphlab.canvas.set_target('ipynb'), for 'browser', it works fine.


User 3266 | 7/8/2016, 2:16:50 PM

Same problem here with 1.10.1, not solved yer