Dato Launcher error "failed to create process" on Windows 7

User 2296 | 9/23/2015, 12:48:30 PM

This is on a Windows 7 64-bit system. The Dato Launcher installation completed without apparent error. If I click on "Terminal", it opens a cmd window with the directory set to the Dato Launcher installation directory. If I click "IPython Notebook", I also get a cmd window, but there is the tail end of an error message at the top:

"failed to create process."

and it does not start IPython Notebook, but rather the same cmd window as clicking on "Terminal".

I've already tried installing GraphLab Create without the Dato Launcher, using pip and virtualenv. That failed because, I believe, I have a 32-bit version of Python, due to other package dependencies. I'd be willing to install the 64-bit version of Python as well, but figured that if I need to install yet another Python (already have 2.7 and 3.4 32-bit...), I might as well let the Dato Launcher installer do it.

Is there something I can do that would help diagnose this? Is there an equivalent sequence of commands I can try, to see which is having a problem?

(I'm in the same Coursera Machine Learning course as Andrey, who posted about another installation issue a bit earlier.)

Comments

User 4 | 9/23/2015, 6:32:57 PM

Hi @ptressel, this is not an expected error. You should be able to launch IPython Notebook successfully from the Dato Launcher on Windows 7 64-bit.

I suspect the "failed to create process" error is coming from the ipython notebook command. Can you try running this command in a Terminal window created by the launcher? If it doesn't work, can you also try ipython (without the notebook) to see if that one can succeed? Thanks!


User 2296 | 9/25/2015, 1:37:54 AM

Thanks, Zach!

Yes, both "ipython notebook" and the "ipython" command alone get the "failed to create process" error.

The correct python is being found in the launcher terminal -- starting python gets the version from Anaconda installed by the Dato Launcher installer. Just in case, I removed my default Python installation from my Windows Path, and also removed cygwin's bin. Also found and removed an old _ipython folder in my user profile directory. None of those made a difference.

I can start ipython from within Python, like this:

C:\Program Files (x86)\Dato Launcher>python from IPython import startipython startipython()

That starts IPython in the terminal, without a browser.

The "failed to create process." message appears in this file:

AppData\Local\Dato\Dato Launcher\Scripts\ipython.exe

It seems command line options to "ipython" are being ignored. I tried "ipython -h", which should not try to start a browser session or even a terminal session, and that got the same error. Likewise "ipython --no-browser".

I see some instances of this error on stackoverflow (where there is no mention of whether ipython was installed from Anaconda) and on the Anaconda mailing list, e.g.:

https://groups.google.com/a/continuum.io/forum/#!topic/anaconda/Q0pqBjgn7nQ

As mentioned there, the "conda" command also gets the same error. I turned off my firewall (which doesn't cause any problems for Mathjax in other applications) -- no change.


User 2296 | 9/25/2015, 2:23:23 AM

I just tried importing graphlab in a Dato Launcher terminal, directly in python, and in ipython started from python as above. It's not there... import graphlab Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: No module named graphlab The installation process did not report an error. But I wonder...is there an installation log?

I'm going to try installing 64-bit Python 2.7 directly and do the "by hand" installation, not using Anaconda, since this is for the UW / Dato Coursera course and there's a deadline in < 3 days. I won't disturb the Dato Launcher installation, so we can continue here. I should mention...I'm in Seattle, so if it's any use, I could bring in the machine...)


User 2296 | 9/25/2015, 5:47:49 AM

As a baseline comparison, I installed Python 2.7.10 64-bit and followed the fall-back installation instructions using virtualenv -- this works. (I also have 32-bit versions of 2.7.10 and 3.4, so all are in distinct directories.)

But that's not about the Dato Launcher installation -- it just shows that GraphLab itself will install properly, which helps to isolate the issue to either the Dato Launcher installation or the Anaconda installation.

Off topic, but suggestions for the instructions at https://dato.com/download/install-graphlab-create-command-line.html would be: Say that 64-bit Python 2.7 is required. Show or mention the -p option to virtualenv in case people already have other versions of Python.


User 2296 | 9/26/2015, 9:09:34 AM

It appears that "failed to create process" is a popular Python-related error on Windows systems. Various speculations relate it to spaces in the path, or access permissions on various folders. Here are a few sample posts:

https://groups.google.com/a/continuum.io/forum/#!topic/anaconda/wlibvnzd7QA

http://stackoverflow.com/questions/23572498/how-to-diagnose-failure-to-create-process-when-running-windows-executable-from-a

Just to catch the thread up on discussions elsewhere... I re-installed the new version of the Launcher, which got the "failed to create process" while the Launcher was completing the installation. I tried re-running the Launcher as Administrator, but it failed with the same error. So it's not just a permission problem.


User 2754 | 12/7/2015, 11:12:59 PM

@Zach the suggestion you gave doesn't work for me. How do I fix it?


User 2965 | 1/6/2016, 2:04:10 AM

I have GraphLab create installed on a windows 8 64 bit machine.

When using the "TERMINAL" button the command prompt opens without errors, but then when I run ipython I get the this error:

failed to create process

when trying to work around this issue, I am able to launch simply "python" instead of "ipython" and able to import graphlab, and import the sample "songs" data, but then using lambdas is not working - see error below:

songs['numwords'] = songs['title'].apply(lambda x: len(x.split(' '))) Traceback (most recent call last): File "<stdin>", line 1, in <module> File "C:\Users\username\AppData\Local\Dato\Dato Launcher\lib\site-packages\graphlab\da tastructures\sarray.py", line 1693, in apply return SArray(proxy=self.proxy.transform(fn, dtype, skipundefined, seed)) File "C:\Users\username\AppData\Local\Dato\Dato Launcher\lib\site-packages\graphlab\cy thon\context.py", line 49, in exit raise exctype(excvalue) RuntimeError: Runtime Exception. Unable to evaluate lambdas. Lambda workers did not start.

Any suggestions on what to do?

When using the IPYTHON NOTEBOOK button, the command prompt open with "failed to create process" error starting from the top, and trying to run anything results in the same error:

--------------------ipython notebook starting point----------------------------- failed to create process. Welcome to the GraphLab Create Terminal

This terminal gives you access to the GraphLab Create Python environment with a number of useful packages including ipython, ipython notebook, scikit-learn and numpy. Use 'conda' or 'pip' to manage packages for development.

To get started, launch 'ipython' and 'import graphlab'

C:\Users\username\AppData\Local\Dato\Dato Launcher>ipython failed to create process.

C:\Users\username\AppData\Local\Dato\Dato Launcher>conda failed to create process.

C:\Users\username\AppData\Local\Dato\Dato Launcher>pip failed to create process.

C:\Users\username\AppData\Local\Dato\Dato Launcher>


User 940 | 1/6/2016, 7:29:03 PM

Hi @mobigital ,

Which version of GLC are you using? This will help us debug.

Cheers! -Piotr


User 2965 | 1/15/2016, 4:16:01 AM

I just saw, @piotr , that you asked the question, for some reason Dato Launcher does not have a version, neither Help, Advanced or Edit menu in the GUI provide an "About..." menu, OK so I looked in the initial trial email (no version there), and then looked at the downloaded installation .exe - that has a version: dato-launcher-1.2.2-2.exe

(I updated my notification preferences - so I should get an email if you post more questions here, will try to help as much as possible)


User 940 | 1/15/2016, 7:34:46 PM

Hi @mobigital ,

This is good feedback, and we'll take it into account. This could be clearer. What you found was the version of the launcher. The version I was looking for was when you into the python interpreter, and then type

python import graphlab graphlab.version

What is the result of this?

Cheers! -Piotr


User 2965 | 1/15/2016, 9:26:28 PM

Version 1.7.1

C:\Users\username\AppData\Local\Dato\Dato Launcher>python Python 2.7.10 |Anaconda 2.3.0 (64-bit)| (default, May 28 2015, 16:44:52) [MSC v.1500 64 bit (AMD64)] on win32 Type "help", "copyright", "credits" or "license" for more information. Anaconda is brought to you by Continuum Analytics. Please check out: http://continuum.io/thanks and https://binstar.org '>>> import graphlab '>>> graphlab.version '1.7.1' '>>>


User 4736 | 4/14/2016, 1:44:20 AM

i'm having the same error with running scrapy shell https://news.google.com/ I'm running C:\Users\<user>\Anaconda2 Python 27 64 bit on Window 10. I get failed to create process. I've tried setting path var to include Anaconda2 python directories with scripts and base dir. scrapy works with spyder, but can't get shell to work.

any help would be appreciated.


User 4 | 4/14/2016, 5:13:52 AM

Hi @jw_smitty, that doesn't seem like a problem related to GraphLab Create or Dato Launcher. You might want to follow up with the scrapy community (not sure whether they have a forum) or Continuum Analytics (the makers of Anaconda Python). From my initial searches it seems that "failed to create process" is a very common problem with Python installations on Windows, and has various causes.