RuntimeError: Runtime Exception. LOG_FATAL encountered

User 2292 | 9/22/2015, 7:15:57 PM

I'm using datascientistworkbench.com for Cousera course: "Machine Learning Foundations: A Case Study Approach". I downloaded and installed graphlab-create and installed my license at the site.

I'm getting exception when I execute following. Appreciate reading this post. Thanks Arvind. sf = graphlab.SFrame('people-example.csv') sf['Country'] = sf['Country'].apply(transform_country)


RuntimeError Traceback (most recent call last) <ipython-input-33-58b2d3ea026a> in <module>() ----> 1 sf['Country'].apply(transform_country)

/home/notebook/kaenv/lib/python2.7/site-packages/graphlab/datastructures/sarray.pyc in apply(self, fn, dtype, skipundefined, seed) 1624 1625 with cythoncontext(): -> 1626 return SArray(proxy=self.proxy.transform(fn, dtype, skipundefined, seed)) 1627 1628

/home/notebook/kaenv/lib/python2.7/site-packages/graphlab/cython/context.pyc in exit(self, exctype, excvalue, traceback) 47 if not self.showcythontrace: 48 # To hide cython trace, we re-raise from here ---> 49 raise exctype(exc_value) 50 else: 51 # To show the full trace, we do nothing and let exception propagate

RuntimeError: Runtime Exception. LOG_FATAL encountered

Comments

User 1319 | 9/22/2015, 9:21:22 PM

You should use

sf = graphlab.SFrame.read_csv ('people-example.csv')

Assuming you started IPython Notebook from the same directory that contains the file people-example.csv. Otherwise you need to include the file's path.


User 15 | 9/22/2015, 9:27:02 PM

Hi Arvind,

It's puzzling that those commands from the notebook don't work on your machine. In the notebook output, around where you created the SFrame, there should be a path to a log file. Would you be able to post this file to this forum?

Thanks, Evan


User 2292 | 9/22/2015, 9:38:44 PM

I'm not running these commands in my machine, I'm using Data Scientist Workbench, IBM cloud tool run/share iPython notebooks. Everything is set up in the cloud. I wanted to use the cloud workbench instead of setting up on my computer(I'm going to try that, I'm sure it would work).

I executed following commands in the python notebook to install graphlab-create, I did not get any exceptions. All command to load csv file and to display graphlab canvas worked, except the apply() command.

!pip install graphlab-create !pip install --upgrade https://get.dato.com/GraphLab-Create/1.6/{email address}/{key}/GraphLab-Create-License.tar.gz

I'll not sure if I could get the log file.

Thanks Arvind


User 15 | 9/22/2015, 10:25:38 PM

I see. The log file will be crucial to diagnosing this problem. Seeing that the problem arose when apply was called, it is very probable that it is an environmental issue on the cloud machine. I've never used the Data Scientist Workbench, so I don't know what that could be without the log.


User 2292 | 9/24/2015, 4:45:34 PM

I have attached the log file, this is only happening in the cloud environment, no issues running locally in my laptop.

Errors in the log file:

1443112776 : INFO: (commitglobalifoutofdate:515): num elements: 0 rowsprocessed: 7 time:0.000461 1443112776 : ERROR: (operator():272): Min value not available for a non-numeric column 1443112780 : INFO: (newcache:157): Cache Utilization:71680 1443112780 : INFO: (deletepathimpl:299): Deleting cache://tmp/000033.0000 1443112780 : INFO: (deletepathimpl:299): Deleting cache://tmp/000033.sidx 1443112781 : INFO: (transform:396): Function entry 1443112781 : ERROR: (operator():210): Check failed (/var/lib/jenkins/jobs/Dato-Dev-Continuous-Build-Linux/workspace/osssrc/fileio/temp_files.cpp:210): success

1443112781 : ERROR: (operator():210): Check failed (/var/lib/jenkins/jobs/Dato-Dev-Continuous-Build-Linux/workspace/osssrc/fileio/tempfiles.cpp:210): success

1443112781 : FATAL: (createcurrentprocesstempdirectory:214): Unable to create temporary directories at /var/tmp/graphlab-notebook/482


User 3531 | 3/14/2016, 11:52:36 AM

I meet the same issues. Here is my log. I'm in Ubuntu14.04 Anaconda2.5.0 Python2.7.11.

How you guys fix it? Thanks! :)


User 1207 | 3/14/2016, 5:57:56 PM

Hello,

I'm not sure what's going on -- it appears that something messes with the permissions of /var/tmp, and GLC is not able to write there.

I think one way around this is to set the environment variable GRAPHLABCACHEFILELOCATIONS to a different directory. This can be done by running gl.setruntimeconfig("GRAPHLABCACHEFILELOCATIONS", "<path to temp dir>") when you first start graphlab, or by setting it as an environment variable before you start python. For example, I ran gl.setruntimeconfig("GRAPHLABCACHEFILE_LOCATIONS", "/home/hoytak/tmp") to test this.

Hope that helps!

-- Hoyt


User 3330 | 3/28/2016, 6:54:22 AM

Hoyt,

I think you hit the nail on the head. This is a problem with the GRAPHLABCACHEFILELOCATIONS and changing it through the gl.setruntime_config() should solve the problem!!

  • best