GraphLab not finding GPU

User 2244 | 9/15/2015, 12:15:08 AM

I've installed CUDA and the gpu version of graphlab-create ('sudo pip install graphlab-create-1.5.2.gpu.tar.gz' — no complaints from the shell.) on my machine. CUDA's deviceQuery seems happy (see below). Unfortunately, testing with the MNIST handwritten digits example shows that the GPU is not being found:

PROGRESS: Computing mean image... PROGRESS: Done computing mean image. PROGRESS: For Nvidia GPU CUDA support, please pip install http://static.dato.com/files/graphlab-create-1.5.2.gpu.tar.gz PROGRESS: Creating neuralnet using cpu

Elapsed time is about 35 seconds ...

Is there some way I can verify that GraphLab is finding the GPU-enabled version of graphlab-create? And if it is not, what do I need to do differently?

Here's what CUDA says:

deviceQuery Starting... CUDA Device Query (Runtime API) version (CUDART static linking) Detected 1 CUDA Capable device(s) Device 0: "GeForce GT 750M" CUDA Driver Version / Runtime Version 7.5 / 7.5 CUDA Capability Major/Minor version number: 3.0 Total amount of global memory: 2040 MBytes (2138992640 bytes) ( 2) Multiprocessors, (192) CUDA Cores/MP: 384 CUDA Cores GPU Max Clock rate: 967 MHz (0.97 GHz) Memory Clock rate: 2500 Mhz Memory Bus Width: 128-bit L2 Cache Size: 262144 bytes Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096) Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers Total amount of constant memory: 65536 bytes Total amount of shared memory per block: 49152 bytes Total number of registers available per block: 65536 Warp size: 32 Maximum number of threads per multiprocessor: 2048 Maximum number of threads per block: 1024 Max dimension size of a thread block (x,y,z): (1024, 1024, 64) Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535) Maximum memory pitch: 2147483647 bytes Texture alignment: 512 bytes Concurrent copy and kernel execution: Yes with 1 copy engine(s) Run time limit on kernels: Yes Integrated GPU sharing Host Memory: No Support host page-locked memory mapping: Yes Alignment requirement for Surfaces: Yes Device has ECC support: Disabled Device supports Unified Addressing (UVA): Yes Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0 Compute Mode: < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) > deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 7.5, CUDA Runtime Version = 7.5, NumDevs = 1, Device0 = GeForce GT 750M Result = PASS

Comments

User 940 | 9/15/2015, 5:18:36 PM

Hey, could you try pip uninstall graphlab-create followed by pip install --upgrade --no-cache-dir http://static.dato.com/files/graphlab-create-1.5.2.gpu.tar.gz?

I think there was a package naming problem which confuses pip. If graphlab-create was already installed, pip thinks there's nothing more to install even though you want to upgrade to the gpu version.

Let me know if that doesn't work!

Cheers! -Piotr


User 2244 | 9/15/2015, 8:10:35 PM

Thanks for the suggestion Piotr. I had tried the uninstall, follwed by install, and that hadn't worked. To my surprise, what did work was re-booting. (Not used to needing a Windows-ish solution on my linux box.)


User 2244 | 9/15/2015, 8:10:39 PM

Thanks for the suggestion Piotr. I had tried the uninstall, follwed by install, and that hadn't worked. To my surprise, what did work was re-booting. (Not used to needing a Windows-ish solution on my linux box.)