Runing "cmake ." under my own app subdirectory meet error

User 2080 | 8/30/2015, 7:40:10 AM

hello everyone . When I learned Distributed Graph-Parallel API 2.2 documentation. It told me how to write first app(hello world) use Powergraph's API. I thougt I did exactly as the docs. First write CMakeLists.txt and myapp.cpp under subdirectory "Powergraph/apps/myapp" . Then I run "cmake ." command to get the Makefile. But I got an error. It seems like this:

CMake Error at CMakeLists.txt:3 (addgraphlabexecutable): Unknown CMake command "addgraphlabexecutable".

As API told me , "addgraphlabexecuteable" is a CMake macro that will compile a program called myapp using the CPP file myapp.cpp, and linking in all GraphLab libraries and dependencies. And I found that the macro "addgraphlabexecuteable" in "Powergraph/CMakeLists.txt". I think maybe I should include this file in my own CMakeLists.txt which is in "Powergraph/apps/myapp" . But I don't know how to realize this.

Is there any suggestions ? Regards

Comments

User 1592 | 8/31/2015, 6:07:55 AM

Hi After you write you application, you need to configure again (at the root PowerGraph folder) to detect the new app. You should compile under PowerGraph/release/apps/myapp

Please note that PowerGraph project is deprecated, and we give very limited support for it. We have a newer project called Dato Core in github.


User 2080 | 9/2/2015, 3:03:20 AM

thank you :smile: I solved this problem with an answer that you gave before . regards