Using the GPU

User 2001 | 8/25/2015, 12:26:29 PM

I'm trying to run the Convolutional Net MNIST example on the GPU. I'm using CUDA 7.0 and Ubuntu 14.10.

When I try running the code, I get the following, indicating that GraphLab is running on the cpu:


PROGRESS: For Nvidia GPU CUDA support, please pip install http://static.dato.com/files/graphlab-create-1.5.2.gpu.tar.gz PROGRESS: Creating neuralnet using cpu


I tried following these exact instructions and ran the code again, but got the same message. Still using the cpu.

The output I get for running the pip install command above seems to suggests everything should be fine, as I get the following output:


Downloading/unpacking http://static.dato.com/files/graphlab-create-1.5.2.gpu.tar.gz Downloading graphlab-create-1.5.2.gpu.tar.gz (96.4MB): 96.4MB downloaded Running setup.py (path:/tmp/pip-tuN3BE-build/setup.py) egginfo for package from http://static.dato.com/files/graphlab-create-1.5.2.gpu.tar.gz Requirement already satisfied (use --upgrade to upgrade): GraphLab-Create==1.5.2 from http://static.dato.com/files/graphlab-create-1.5.2.gpu.tar.gz in /usr/local/lib/python2.7/dist-packages Requirement already satisfied (use --upgrade to upgrade): boto==2.33.0 in /usr/local/lib/python2.7/dist-packages/boto-2.33.0-py2.7.egg (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): librato-metrics==0.4.9 in /usr/local/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): mixpanel-py==3.1.1 in /usr/local/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): decorator==3.4.0 in /usr/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): tornado==4.1 in /usr/local/lib/python2.7/dist-packages/tornado-4.1-py2.7-linux-x8664.egg (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): prettytable==0.7.2 in /usr/local/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): requests==2.3.0 in /usr/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): awscli==1.7.27 in /usr/local/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): sseclient==0.0.8 in /usr/local/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): multipledispatch>=0.4.7 in /usr/local/lib/python2.7/dist-packages (from GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python2.7/dist-packages (from librato-metrics==0.4.9->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): certifi in /usr/local/lib/python2.7/dist-packages (from tornado==4.1->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): backports.ssl-match-hostname in /usr/local/lib/python2.7/dist-packages (from tornado==4.1->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): botocore>=0.108.0,<0.109.0 in /usr/local/lib/python2.7/dist-packages (from awscli==1.7.27->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): bcdoc>=0.14.0,<0.15.0 in /usr/local/lib/python2.7/dist-packages (from awscli==1.7.27->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): colorama>=0.2.5,<=0.3.3 in /usr/lib/python2.7/dist-packages (from awscli==1.7.27->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): docutils>=0.10 in /usr/local/lib/python2.7/dist-packages (from awscli==1.7.27->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): rsa>=3.1.2,<=3.1.4 in /usr/local/lib/python2.7/dist-packages (from awscli==1.7.27->GraphLab-Create==1.5.2) Requirement already satisfied (use --upgrade to upgrade): jmespath==0.7.1 in /usr/local/libMarkdown`�I�M! ��7# ++����FYI: If you are using Anaconda and having problems with NumPyHello everyone,

I ran into an issue a few days ago and found out something that may be affecting many GraphLab users who use it with Anaconda on Windows. NumPy was unable to load, and consequently everything that requires it (Matplotlib etc).

It turns out that the current NumPy build (1.10.4) for Windows is problematic (more info here).

Possible workarounds are downgrading to build 1.10.1 or forcing an upgrade to 1.11.0 if your dependencies allow. Downgrading was easy for me using conda install numpy=1.10.1

Thanks for your attention!

RafaelMarkdown558,824,8414L���4L���179.110.206.156179.110.206.1564P�}��Xj�8\j�1str�"��\j�Xj��\j�8bj�րi�1(׀i�

Comments

User 1190 | 8/25/2015, 5:17:21 PM

Hi Joeetaku,

The installation looks fine. The problem is most likely a driver issue.

Can you send us the server log for the session where neuralnet is running using cpu? You can locate the server log by looking for the message when graphlab is first used:

[INFO] Start server at: ipc:///tmp/graphlab_server-12170 - Server binary: /Users/jay/anaconda/lib/python2.7/site-packages/graphlab/unity_server - Server log: /tmp/graphlab_server_1440522907.log

Thanks, -jay


User 2001 | 8/26/2015, 7:18:12 AM

Ok will do. However I seem to be unable to copy the entire log into a post due to its length, and for some reason I can't seem to attach it as a file either. Is there a certain segment of it you need to see? Maybe I could just just copy that over?

Not sure if it's relevant but I should also add that I have no problem running on the GPU using other machine learning toolkits such as Theano.


User 940 | 8/27/2015, 5:45:00 PM

@Joeetaku

I sent you a message with my e-mail, you should send it there.