Upgrade from v1.4.0 to v1.5.1

User 2096 | 7/21/2015, 8:52:14 PM

Hi,

I'm trying to upgrade GraphLab Create to the latest version. The upgrade completes without any error. However, when I try to import it in Python, it doesn't see the updated version. I'm using Mac OS X 10.10.4 (Yosemite).

Here is the terminal dump:

	enthusiastic:~ enthusiastic$ pip install --upgrade graphlab-create
	/Library/Python/2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
	  InsecurePlatformWarning
	Requirement already up-to-date: graphlab-create in /Library/Python/2.7/site-packages
	Requirement already up-to-date: boto==2.33.0 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: prettytable==0.7.2 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: decorator==3.4.0 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: librato-metrics==0.4.9 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: multipledispatch>=0.4.7 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: sseclient==0.0.8 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: requests==2.3.0 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: awscli==1.7.27 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: mixpanel-py==3.1.1 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: tornado==4.1 in /Library/Python/2.7/site-packages (from graphlab-create)
	Requirement already up-to-date: six in /Library/Python/2.7/site-packages (from librato-metrics==0.4.9->graphlab-create)
	Requirement already up-to-date: botocore<0.109.0,>=0.108.0 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: bcdoc<0.15.0,>=0.14.0 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: colorama<=0.3.3,>=0.2.5 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: docutils>=0.10 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: rsa<=3.1.4,>=3.1.2 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: certifi in /Library/Python/2.7/site-packages (from tornado==4.1->graphlab-create)
	Requirement already up-to-date: backports.ssl-match-hostname in /Library/Python/2.7/site-packages (from tornado==4.1->graphlab-create)
	Requirement already up-to-date: jmespath==0.7.1 in /Library/Python/2.7/site-packages (from botocore<0.109.0,>=0.108.0->awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: python-dateutil<3.0.0,>=2.1 in /Library/Python/2.7/site-packages (from botocore<0.109.0,>=0.108.0->awscli==1.7.27->graphlab-create)
	Requirement already up-to-date: pyasn1>=0.1.3 in /Library/Python/2.7/site-packages (from rsa<=3.1.4,>=3.1.2->awscli==1.7.27->graphlab-create)

	enthusiastic:~ enthusiastic$ python

	Python 2.7.9 |Anaconda 2.2.0 (x86_64)| (default, Dec 15 2014, 10:37:34)
	[GCC 4.2.1 (Apple Inc. build 5577)] on darwin
	Type "help", "copyright", "credits" or "license" for more information.
	Anaconda is brought to you by Continuum Analytics.
	Please check out: http://continuum.io/thanks and https://binstar.org

	>>> import graphlab as gl
	A newer version of GraphLab Create (v1.5.1) is available! Your current version is v1.4.0.
	New features in 1.5:
	- Numpy integration with SArray
	- Random decision forest for classicaiton and regression
	- Image similarity searchMarkdown`�I�M!	��7#	++����FYI: If you are using Anaconda and having problems with NumPyHello everyone,

I ran into an issue a few days ago and found out something that may be affecting many GraphLab users who use it with Anaconda on Windows. NumPy was unable to load, and consequently everything that requires it (Matplotlib etc).

It turns out that the current NumPy build (1.10.4) for Windows is problematic (more info here).

Possible

Comments

User 4 | 7/22/2015, 5:59:31 AM

I'm not sure why pip install --upgrade graphlab-create wouldn't pick up the correct version. Can you try pip install graphlab-create==1.5.1? If that doesn't work, can you post the error output, along with Python version (python -V) and pip version (pip -V)?


User 2096 | 7/22/2015, 1:07:43 PM

	enthusiastic:~ enthusiastic$ pip install graphlab-create==1.5.1
	Requirement already satisfied (use --upgrade to upgrade): graphlab-create==1.5.1 in /Library/Python/2.7/site-packages
	Requirement already satisfied (use --upgrade to upgrade): boto==2.33.0 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): prettytable==0.7.2 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): decorator==3.4.0 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): librato-metrics==0.4.9 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): multipledispatch>=0.4.7 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): sseclient==0.0.8 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): requests==2.3.0 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): awscli==1.7.27 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): mixpanel-py==3.1.1 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): tornado==4.1 in /Library/Python/2.7/site-packages (from graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): six in /Library/Python/2.7/site-packages (from librato-metrics==0.4.9->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): botocore<0.109.0,>=0.108.0 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): bcdoc<0.15.0,>=0.14.0 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): colorama<=0.3.3,>=0.2.5 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): docutils>=0.10 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): rsa<=3.1.4,>=3.1.2 in /Library/Python/2.7/site-packages (from awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): certifi in /Library/Python/2.7/site-packages (from tornado==4.1->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): backports.ssl-match-hostname in /Library/Python/2.7/site-packages (from tornado==4.1->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): jmespath==0.7.1 in /Library/Python/2.7/site-packages (from botocore<0.109.0,>=0.108.0->awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): python-dateutil<3.0.0,>=2.1 in /Library/Python/2.7/site-packages (from botocore<0.109.0,>=0.108.0->awscli==1.7.27->graphlab-create==1.5.1)
	Requirement already satisfied (use --upgrade to upgrade): pyasn1>=0.1.3 in /Library/Python/2.7/site-packages (from rsa<=3.1.4,>=3.1.2->awscli==1.7.27->graphlab-create==1.5.1)

	enthusiastic:~ enthusiastic$ python
	Python 2.7.9 |Anaconda 2.2.0 (x86_64)| (default, Dec 15 2014, 10:37:34)
	[GCC 4.2.1 (Apple Inc. build 5577)] on darwin
	Type "help", "copyright", "credits" or "license" for more information.
	Anaconda is brought to you by Continuum Analytics.
	Please check out: http://continuum.io/thanks and https://binstar.org
	>>> import graphlab
	A newer version of GraphLab Create (v1.5.1) is available! Your current version is v1.4.0.
	New features in 1.5:
	- Numpy integration with SArray
	- Random decision forest for classicaHTTP/1.1 200 OK

Transfer-Encoding: chunked Date: Thu, 21 Jul 2016 23:13:36 GMT Server: Warp/3.2.6 Content-Type: application/json

016A ["37zyefqi2sweveyp","42fn7zeo6v5ui427","66pt5sk2wz2jrbzu","awoljknjigytdyls","cj2lanoogknwopto","cnm3adnh35xmsx3f","ebxs4t2y6xr5izzy","eg5zus2pz72mr7xb","exshwew2w2jv3n7r","hxrxgzvgms3incmf","hymu5oh2f5ctk5jr","jkisbjnul226jria","lag7djeljbjng6bu","o3l65o4qzcxs327j","qsk2jzo2zh523r24","t7k6g7fkndoggutd","xfllvjyax4inadxh","ygtjzi2wkfonj3z7","yycjajwpguyno4je"] 0


User 4 | 7/22/2015, 10:41:55 PM

Hmm, it looks like your pip binary is coming from the system installation of Python, while your python version is coming from an Anaconda python installation, so the pip installed packages aren't the ones being used by the Anaconda python. I'm not sure how this could happen, since Anaconda also distributes a version of pip. Is it possible that you have removed pip from your Anaconda Python installation, and thus it's finding the system version of pip instead?

You can confirm this mismatch by looking at the output of which pip and which python. They should be located in the same directory. If there is a mismatch, then packages won't get loaded from the path you expect.


User 2096 | 7/23/2015, 2:27:25 AM

You are right. That's the reason. How do I fix this?

Edit: It works after I commented the line export PATH="/usr/local/bin:$PATH" from .bash_profile. The file now looks like this:

export JAVA_HOME=$(/usr/libexec/java_home)

# added by Anaconda 2.1.0 installer
export PATH="/Users/enthusiastic/anaconda/bin:$PATH"
# export PATH="/usr/local/bin:$PATH"

Is this the right way to fix this?


User 4 | 7/23/2015, 4:47:37 AM

Try reversing the order of the 'export PATH' commands. If the Anaconda command is last, then the Anaconda path will get used first for all Python related binaries. I think that would be the desired behavior.


User 2096 | 7/23/2015, 3:26:48 PM

Thanks! It works. :)