GraphLab Create 1.5.1 on Mac OS X 10.8 (Mountain Lion)

User 4 | 7/21/2015, 8:03:58 PM

Due to a bug in 1.5.1, GraphLab Create crashes upon launch in Mac OS X 10.8. We are working on a fix, but in the meantime, you can use an earlier release of GraphLab Create to work around this issue:

  • Follow the usual installation instructions after registering.
  • After installation, in the same environment, run pip install graphlab-create==1.4.1.

After that, you may also need to apply the workaround here to fix a path issue on Mac OS X 10.8 and 10.9.

Comments

User 1190 | 7/24/2015, 1:55:15 AM

apply lambda function seems to be broken for 10.8 even with 1.4.1. Suggest using pip install graphlab-create==1.3


User 2002 | 7/29/2015, 5:25:17 PM

This should now be addressed with the release of GLC 1.5.2.