Cannot use SDK with GraphLab-Create 1.5.1

User 942 | 7/20/2015, 10:41:27 AM

Hello, I did update GraphLab-Create to 1.5.1 from 1.4.1. My SDK project (once recompiled) gives me a linker error (on Mac and on ubuntu).

Traceback (most recent call last):
ImportError: dlopen(/Users/kikohs/work/sptgraph/sptgraph/ext/sptgraph_fast.so, 2): Symbol not found: __ZTVN8graphlab19gl_sarray_referenceE
 Referenced from: /Users/kikohs/work/sptgraph/sptgraph/ext/sptgraph_fast.so
 Expected in: flat namespace in /Users/kikohs/work/sptgraph/sptgraph/ext/sptgraph_fast.so

What's going on?

Thanks

Comments

User 1190 | 7/20/2015, 10:03:02 PM

The SDK is updated to work with 1.5.1. Please download the latest version and try again. Thanks!


User 942 | 7/21/2015, 10:57:39 AM

It works now. Thanks.