unable to import graphlab

User 32 | 6/16/2015, 9:32:40 AM

I was able to install the graphlab-create version 1.4 but when typing "import graphlab" the following error results ,

dlopen(/Users/devendra/anaconda/lib/python2.7/site-packages/graphlab/cython/cyipc.so, 2): Library not loaded: @rpath/libbasedep.so Referenced from: /Users/devendra/anaconda/lib/python2.7/site-packages/graphlab/cython/cy_ipc.so Reason: image not found

Details of my machine are - Mac OSX , 10.9.3

I had graphlab-create version 1.3 earlier which was working fine, but now when re-installing version 1.3 the same error is shown . Also uninstalling and re-installing did not work out as suggested here .. http://forum.dato.com/discussion/comment/1587#Comment_1587 uninstall graphlab-create pip install graphlab-create

Thanks for the help !!

Comments

User 91 | 6/16/2015, 5:57:48 PM

Did you try pip install graphlab-create --no-cache-dir? There seems to be an issue our package with the pip 7 version.


User 32 | 6/17/2015, 1:35:20 AM

yes yes , I tried the command, pip install graphlab-create --no-cache-dir , but the same issue mentioned above is coming . I also tried reverting back to older version of pip, but still the same issue .


User 4 | 6/17/2015, 1:43:15 AM

Hi @Devendra, can you try pip install --upgrade --no-cache-dir graphlab-create? The --upgrade argument may help, since it will force a re-install on top of the current install path.


User 32 | 6/17/2015, 5:00:19 AM

Hello @Zach , I tried this command, but the same error results as above .


User 91 | 6/17/2015, 5:09:51 AM

Can you type the following command in your terminal and then try running python?

export DYLD_LIBRARY_PATH=/Users/devendra/anaconda/lib/python2.7/site-packages/graphlab/cython/

Now, if you run python, can you import graphlab?


User 32 | 6/17/2015, 5:45:35 AM

@srikris ... yes yes, setting the environment variable "DYLDLIBRARYPATH" to above worked . Now I am able to import graphlab successfully . Thanks so much for the quick help and fast resolution .

Actually the variable DYLDLIBRARYPATH was set to "/Developer/NVIDIA/CUDA-6.5/lib" earlier .

Thanks, Devendra


User 32 | 6/17/2015, 5:50:27 AM

@srikris . How should I mark the above posts as being answered . !!