trouble with "import graphlab"

User 2039 | 6/9/2015, 6:41:04 PM

I'm new to graphlab, and I seem to have installed it correctly (install command returned "Successfully installed GraphLab-Create-License-1.4.0"). By the way, I am using a virtual environment using virtalenv.

However, when I start a python session and type the command "import graphlab", I get the following:

Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/Library/Python/2.7/site-packages/graphlab/", line 24, in <module> import as aws File "/Library/Python/2.7/site-packages/graphlab/connect/aws/", line 18, in <module> from ec2 import getcredentials, launchEC2, listinstances, setcredentials, status, terminateEC2 File "/Library/Python/2.7/site-packages/graphlab/connect/aws/", line 25, in <module> import graphlab.connect.server as glserver File "/Library/Python/2.7/site-packages/graphlab/connect/", line 14, in <module> from graphlab.cython.cyipc import PyCommClient as Client ImportError: dlopen(/Library/Python/2.7/site-packages/graphlab/cython/, 2): no suitable image found. Did find: /Library/Python/2.7/site-packages/graphlab/cython/ file too short

I'm not sure what's going wrong. Bear in mind that I'm new to programming, so please forgive any vocabulary errors above.

Thanks very much.


User 2002 | 6/9/2015, 9:05:57 PM

Hi Mingie - can you confirm the pip installer version (pip -V). If it is pip 7, can you confirm you ran the following command incluiding --no-cache-dir flag.

pip install --upgrade --no-cache-dir{email}/{key}/GraphLab-Create-License.tar.gz

Thanks, Punit

User 2039 | 6/10/2015, 9:58:44 PM

Thanks punit.

Pip says pip is in version 7.0.3.

I ran that exact command with "sudo" in front of it. I tried it without sudo, and I got some kind of permission error. Running that command with sudo returns a bunch of stuff with "Successfully installed GraphLab-Create-License-1.4.0" at the end.

All of this was done in a virtual environment using virtualenv.

Thanks again.

User 2039 | 6/10/2015, 10:04:00 PM

OK, I may be a huge idiot. I'm running OSX 10.7.5, and the website says 10.8+ is required.

I guess my next question is: was the error I posted at the top of the thread caused by the fact that I'm running version of OSX? Also, is there any way to use GraphLab on my machine running 10.7.5?

Thanks again.

User 4 | 6/11/2015, 1:22:41 AM

Hi @mingie, unfortunately this type of error is expected on Mac OS X 10.7 or earlier, and I don't know of a way to make it work in that situation. You can try upgrading Mac OS X to 10.8+ and re-installing GraphLab Create, or you could try running a Linux virtual machine (using the same instructions as for running in a Linux VM on Windows). Hope that helps!