Job Execution

User 1952 | 5/21/2015, 9:54:37 PM

Hi

Why when I set a job for async execution with gl.deploy.job.create(add, x = 1, y =2 ), it never get finished and its status remains pending?

Comments

User 91 | 5/22/2015, 1:23:53 AM

Can you provide us with your code steps along with the error logs so we can repro the bug?


User 1952 | 5/22/2015, 7:55:54 AM

I'm running graphlab in hortonworks sandbox (CentOS 6.6). Because python 2.7 wasn't installed by default, I installed it manullay under the name python2.7.

My code file includes following lines:

import graphlab as gl

def add(x, y): return x + y

job = gl.deploy.job.create(add, x = 1, y = 2)

and after I execute this file and want check the status of job, It shows pending and job.get_results() waits for job to finish infinitely.


User 1952 | 5/22/2015, 8:28:53 PM

Hi @srikris With descriptions in my last comment do you think, something is wrong with hdp sandbox?


User 1178 | 5/23/2015, 5:16:51 AM

Hi Andrew,

Let's check a few things here:

  1. Did you run the GraphLab Create code inside a virtual environment after you have installed python 2.7? Inside your python environment, can you print the following and send to us:

import sys print sys.exec_prefix

  1. Can you print out the job's information and see where the job log file is? You can do the following:

print job

It will print out job execution log at the end of the printing, can you check the content of that file?

Ping


User 1952 | 5/23/2015, 6:57:10 AM

Thanks @"Ping Wang"

Your advice was a huge help. I checked the log file and the problem was because of the inability to find the graphlab module by some other module (because of conflicting python installations). I solved it by creating a virtualenv.


User 1178 | 5/25/2015, 11:10:20 PM

I am glad that you have solved the issue. Thanks for letting us know!

Ping