Installation Issues

User 1945 | 5/17/2015, 9:51:28 AM

Hi I am new to graphlab -

I could not use virtual wpp-macbook-pro-20141209-1:GraphLab-Create-1.4.0 taposh$ virtualenv venv-dato Using base prefix '/Users/taposh/anaconda' New python executable in venv-dato/bin/python3 Also creating executable in venv-dato/bin/python ERROR: The executable venv-dato/bin/python3 is not functioning ERROR: It thinks sys.prefix is '/Users/taposh/Downloads/GraphLab-Create-1.4.0' (should be '/Users/taposh/Downloads/GraphLab-Create-1.4.0/venv-dato') ERROR: virtualenv is not compatible with this system or executable

wpp-macbook-pro-20141209-1:GraphLab-Create-1.4.0 taposh$ source venv-dato/bin/activate -bash: venv-dato/bin/activate: No such file or directory

wpp-macbook-pro-20141209-1:GraphLab-Create-1.4.0 taposh$ pip install --upgrade https://get.dato.com/GraphLab-Create/1.4.0/taposh.d.roy@kp.org/24E7-58F3-C337-6207-3CF0-388B-014F-6E98/GraphLab-Create-License.tar.gz Collecting https://get.dato.com/GraphLab-Create/1.4.0/taposh.d.roy@kp.org/24E7-58F3-C337-6207-3CF0-388B-014F-6E98/GraphLab-Create-License.tar.gz Downloading https://get.dato.com/GraphLab-Create/1.4.0/taposh.d.roy@kp.org/24E7-58F3-C337-6207-3CF0-388B-014F-6E98/GraphLab-Create-License.tar.gz Collecting graphlab-create>=1.4.0 (from GraphLab-Create-License==1.4.0) Downloading GraphLab-Create-1.4.0.tar.gz (53.3MB) 100% |████████████████████████████████| 53.3MB 5.8kB/s Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 20, in <module

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/46/zm1hrxpx0qxd1phxpr931fr40000gr/T/pip-build-t6ot80dz/graphlab-create

w

Comments

User 1592 | 5/17/2015, 5:41:59 PM

Hi Overfitter, Can it be that the python version called is 3 instead of 2.7? You will need to make sure you use python 2.7 as we do not support python 3 yet.


User 4 | 5/18/2015, 9:00:43 PM

I noticed you are already running Anaconda Python 3.x. According to Anaconda's download page, they support running Python 2.7 in an Anaconda 3.x environment. You can follow the instructions here to create a Python 2.7 conda environment.