no module named _winreg

User 1900 | 5/8/2015, 6:45:24 AM

Hi, I am currently trying some examples from the user guide, but have found some issues with some commands, like: g.edges['relation'] = g.edges['relation'].apply(lambda x: x[0].upper())

The problem is my operating systems are windows and when I use the official graphlab VM for windows, everything works fine, but when I tried to install the graphlab on a Ubuntu directly and the command above will give an error saying that no module named _winreg.

I know that _winreg is a windows only module but what really confuses me is that the official graphlab for windows is also a VM environment of Ubuntu. Then, I tried to set up a Ubuntu VM on my windows and install the graphlab on this VM environment, again the error popped up.

Can anyone help with this issue? Is there a solution that I can run this command correctly on a Ubuntu system?

Comments

User 398 | 5/8/2015, 5:15:14 PM

Hi Joshtrick,

Thanks for trying GraphLab Create. I'm slightly confused by your description of the problem. You were using our official VM and it was working fine, but then you tried to install GraphLab on an actual Ubuntu box (not the VM) and you ran into this issue? Can you tell me the version of Ubuntu and Python? Are you using the latest release (1.3)? Can you try a fresh install of GraphLab Create in a new Python virtualenv?

Robert


User 1900 | 5/11/2015, 2:20:29 AM

Hi Robert, Thanks for your reply.

Our situation is this: we are trying to import the operating system which contains GraphLab to a Linux based server. The official VM seems not compatible with the Linux based server cuz I think it is for windows only. Then we tried to import an Ubuntu 14.04 (fresh install) to the server and installed the graphlab 1.3 and python 2.7 on the Ubuntu 14.04. After running the command on the Ubuntu 14.04, the error popped up.

Yes we installed the latest 1.3 version, but not quite sure if it is installed in a python virtualenv. Will this be the problem?

Kind regards, Hao


User 1900 | 5/11/2015, 5:08:18 AM

Hi Robert, It works now. The problem is indeed that we didn't install graphlab in a virtualenv

Thanks Hao